Aktyw Forum

Zarejestruj się na forum.ep.com.pl i zgłoś swój akces do Aktywu Forum. Jeśli jesteś już zarejestrowany wystarczy, że się zalogujesz.

Sprawdź punkty Zarejestruj się

Kurs Programowanie Aplikacji Mobilnych

Moderator: Jacek Bogusz

whiteman
-
-
Posty: 18
Rejestracja: 18 sty 2012, o 21:45

Kurs Programowanie Aplikacji Mobilnych

Postautor: whiteman » 9 lut 2015, o 14:37

Witam,

Muszę npisać kilka słów na temat nowego kursu na łamach EP.
Już od dłuższego czasu żaden inny kurs nie wzbudził we mnie takiego entuzjazmu i uważam, że jest to STRZAŁ W DZIESIĄTKĘ!!!
Gratulacje pomysłu i realizacji dla Autora.
Co prawda po jednym artykule wstępnym trudno oceniać i przewidywać co będzie dalej, ale jak na razie poziom i wyjaśnienia są bardzo rzeczowe i dostosowane jak sądzę do wiedzy i praktyki potencjalnych zainteresowanych "elektroników praktyków", których wiedza programistyczna dotyczy głównie programowania mikrokontrolerów (oczywiście nie chcę tu generalizować).

W każdym razie JESZCZE RAZ GRATULACJE I POZDROWIENIA DLA AUTORA.
Tak trzymać!!!

PS. Z niecierpliwością czekam na kolejne odcinki kursu, bo pomysłów na wykorzystanie tej wiedzy mam już mnóstwo.

Awatar użytkownika
Jacek Bogusz
-
-
Posty: 470
Rejestracja: 12 maja 2010, o 17:37
Lokalizacja: Poznań
Kontaktowanie:

Re: Kurs Programowanie Aplikacji Mobilnych

Postautor: Jacek Bogusz » 11 lut 2015, o 09:31

Przyszły takie czasy, że czasami łatwiej i taniej użyć do sterowania czymś tam telefonu lub tabletu niż od nowa budować całą aplikację. Wśród projektów mamy zaplanowane kilka urządzeń "androidowych", zobaczymy czy autorzy dadzą radę ;). Trzymam kciuki!

Remo
-
-
Posty: 32
Rejestracja: 22 lis 2003, o 21:00
Lokalizacja: Szczecin
Kontaktowanie:

Re: Kurs Programowanie Aplikacji Mobilnych

Postautor: Remo » 13 mar 2015, o 22:16

Witam,
dołączam się do słów uznania dla Autora kursu- jest to pierwszy kurs po pamiętnym Bascom College w siostrzanej EdW, który tak bardzo mnie zainteresował i "wciągnął" od pierwszej lekcji.

Chciałbym -jeśli można- przytoczyć moje doświadczenie z próbami zbudowania aplikacji, które być może okaże się przydatne dla innych uczestników kursu.
Tak się złożyło, że już w pierwszym odcinku kursu napotkałem na problem, który (jak się szczęśliwie okazało- na krótko) nieco przygasił mój zapał .
Otóż przy próbie zbudowania aplikacji pojawiał się błąd (Error: spawn cmd ENOENT). Spędziłem kilka godzin na poszukiwaniu źródła problemu , bezskutecznie.
Późnym wieczorem postanowiłem napisać do Szanownego Autora prośbę o pomoc (prawdę mówiąc nie liczyłem zbytnio, że uzyskam odpowiedź). Ku mojemu zdziwieniu Pan Marcin Karbowniczek , nie tylko mi odpowiedział, uzyskałem szereg wskazówek dotyczących możliwych przyczyn niepowodzenia. Jedna z nich okazała się być celna i pozwoliła mi na zbudowanie pierwszej w "karierze" aplikacji .

Być może ktoś z Kursantów napotka podobny problem dlatego chciałbym korzystając z tego forum podzielić się informacją jak się z tym uporać.
Jeśli podczas próby zbudowania aplikacji poleceniem cordova build w oknie poleceń pojawia błąd " Error: spawn cmd ENOENT "
-należy w zmiennych środowiskowych systemu (Komputer>Właściwości Systemu>Zaawansowane Ustawienia Systemu>Zmienne Środowiskowe) dla zmiennej PATH dopisać ścieżkę C:\Windows\System32

Z tego miejsca pragnę jeszcze raz serdecznie podziękować Panu Karbowniczkowi za zainteresowanie i pomoc .
Wiedząc, że oprócz przekazywanej wiedzy w artykule na łamach EP można liczyć na pomoc w trudnych sytuacjach, prowadzony kurs dla mnie osobiście nabrał bardziej indywidualnego wymiaru.

Dziękuję i z niecierpliwością czekam na kolejne lekcje.

Awatar użytkownika
Marcin.K
-
-
Posty: 43
Rejestracja: 1 lip 2011, o 12:47

Re: Kurs Programowanie Aplikacji Mobilnych

Postautor: Marcin.K » 28 mar 2015, o 04:32

Jeden z czytelników, podążających za kursem, trafił na problem. Najnowsza obecnie dostępna wersja serwera Node.js nie jest w pełni kompatybilna z niektórymi wersjami Cordovy, a dokładniej to Cordova oczekuje starszej wersji Node.js. Objawia się to błędem (a właściwie ostrzeżeniem) w stylu "cordova-js@3.8.0: wanted {"node":"~0.10.x} <current: {"node":"0.12.0","npm":"2.5.1"}> itd.
My w kursie pracujemy na Cordovie 4.1.2, a najnowsza obecnie to 4.3.0. Node.js mamy w wersji 0.10.35, a najnowsza to 0.12.1. Npm mamy w kursie w wersji 1.4.28.
W kursie zawsze podajemy wersje używanego oprogramowania i użycie ich gwarantuje, że kod będzie działał tak samo, jak u nas. Można też korzystać z najnowszych wersji tych pakietów, ale wtedy trzeba w razie czego rozwiązywać pojawiające się konflikty.

Ten sam czytelnik zwrócił się jeszcze z innym problemem, który również mógł wynikać z wersji oprogramowania. W trakcie próby instalacji Cordovy pojawiał się komunikat UNABLE_TO_VERIFY_LEAF_SIGNATURE. Działo się to w przypadku Node.js w wersji 0.12.0 i npm w wersji 2.5.1. Gdyby problemu nie udało się obejść poprzez zmianę wersji oprogramowania, można ręcznie wyłączyć sprawdzanie certyfikatów podczas pobierania pakietu Cordova, korzystając z polecenia:
npm config set strict-ssl false
W razie czego można następnie przywrócić to zabezpieczenie wpisując w linii komend:
npm config set strict-ssl true

AlexiaEvoft
-
-
Posty: 1
Rejestracja: 3 cze 2019, o 07:16
Lokalizacja: Thailand
Kontaktowanie:

Kurs Programowanie Aplikacji Mobilnych

Postautor: AlexiaEvoft » 6 cze 2019, o 11:19

Ciekawy kurs. Obecnie ilość aplikacji na Androida rośnie z każdym miesiącem. Chętnie spróbuje się czegoś nauczyć:

пробовали королевское казино кто-то пробовал?

Wróć do „Magazyn Elektronika Praktyczna - dyskusje, komentarze”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 0 gości