Aktyw Forum

Zarejestruj się na forum.ep.com.pl i zgłoś swój akces do Aktywu Forum. Jeśli jesteś już zarejestrowany wystarczy, że się zalogujesz.

Sprawdź punkty Zarejestruj się

PCF8574T problem

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

PCF8574T problem

Postautor: mariomaster » 16 mar 2014, o 21:55

Witam,

posiadam dwie identyczne płytki z przedstawionym na zdjęciu PCF8574T które sterują diodami i niestety ostatnio omyłkowo włożyłem odwrotnie taśmę łączącą układ z urządzeniem. Od tego czasu nie działa jedna z płytek stąd podejrzewam że uszkodziłem PCF8574T, więc chciałbym zapytać czy PCF8574T można czymś odczytać ew. zaprogramować wtedy kupując nowy mógłbym to naprawić?
Załączniki
skasuj.jpg
IMAG0169chwilowo2.jpg

virgo
-
-
Posty: 58
Rejestracja: 20 lip 2012, o 20:56

Re: PCF8574T problem

Postautor: virgo » 17 mar 2014, o 09:02

Przecież to nie jest układ programowalny. Po wymianie powinien od razu działać.

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

Re: PCF8574T problem

Postautor: mariomaster » 17 mar 2014, o 11:42

Przecież to nie jest układ programowalny. Po wymianie powinien od razu działać.
No widzisz nie znam tej kości stąd moje pytanie ale jeśli nie jest programowalna to super a jak mogę sprawdzić czy to ona jest walnięta?

virgo
-
-
Posty: 58
Rejestracja: 20 lip 2012, o 20:56

Re: PCF8574T problem

Postautor: virgo » 17 mar 2014, o 16:46

Najpewniejsza byłaby podmiana układu z działającej płytki. Ale jeżeli do tego samego sterownika podpinasz dwie płytki, i jedna działa, a druga nie, to najprawdopodobniej uszkodzony jest ten PCF. Poza nim tam jest 5 części na krzyż (przynajmniej na zdjęciu).

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

Re: PCF8574T problem

Postautor: mariomaster » 24 mar 2014, o 21:14

Wymieniłem te ekspandery na nowe i wszystko działa jak przedtem ale strasznie się grzeją i to już po kilku sekundach są tak gorące, że nie można ich dotknąć. Z obawy przed spaleniem wyłączyłem ale zastanawiam się bo to chyba nie jest normalne?

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: PCF8574T problem

Postautor: Tomasz Gumny » 25 mar 2014, o 02:56

Czy zmierzyłeś napięcie zasilania (8-GND, 16-VCC)?

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

Re: PCF8574T problem

Postautor: mariomaster » 25 mar 2014, o 09:53

Zmierzyłem przed chwilą i wynosi 4,95

Dodano po namyśle:
Czy ktoś mógłby u siebie sprawdzić czy też się tak grzeją bo przecież nie da się ich dotknąć tak parzą a nie chcę ich spalić.

virgo
-
-
Posty: 58
Rejestracja: 20 lip 2012, o 20:56

Re: PCF8574T problem

Postautor: virgo » 25 mar 2014, o 21:01

Czym one sterują, tylko ledami? Wszystkie są w szereg z 330R? Jeżeli tak, to dziwna sprawa. Zmierz, jakie masz napięcia na poszczególnych wyjściach (piny 4-7, 9-12), gdy włączone jest obciążenie. Do czego to jest podłączone i za pomocą czego (długość kabla)? Całość działa prawidłowo? Może jest jakiś problem z pull-upami na SDA/SCL.

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

Re: PCF8574T problem

Postautor: mariomaster » 28 mar 2014, o 11:42

Sprawdziłem napięcie na obydwu wymienionych układach PCF8574T i są te same wartości napięcia przy obiciążeniu na poszczególnych pinach:

4 - 4,78V
5 - 1,75V
6 - 3,55V
7 - 3,55V

9 - 4,75V
10- 4,75V
11- 3,55V
12- 3,55V

Spalone expandery zostały przeze mnie wylutowane i wymienione na nowe i teraz obydwa się tak grzeją więc o co tu chodzi.


Obrazek

Obrazek

Awatar użytkownika
ACeK
-
-
Posty: 1522
Rejestracja: 30 mar 2003, o 19:35
Lokalizacja: Kielce

Re: PCF8574T problem

Postautor: ACeK » 28 mar 2014, o 15:43

Obrazek Jesli uklad sie grzeje sprobuj go jeszcze raz wylutowac. Gdy juz go wylutujesz podlacz (na pajaka) tylko zasilanie do plusa i minusa :idea: 5V. Zobacz czy dalej sie grzeje.
Teraz podlacz plytke bez PCF8574 do sterownika. Uzywajac krotkiego przewodu zrob polaczenie pomiedzy zasilaniem a opornikami przed diodami (tak jakbys symulowal prace ukladu) . W ten sposob sprawdzisz czy dzialaja i nie ma nanich zwarcia.
Dobrze by bylo jakbys zamiescil zdjecie plytki bez wlutowanego ukladu z gory oraz od spodu Obrazek

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

Re: PCF8574T problem

Postautor: mariomaster » 28 mar 2014, o 23:04

Wylutowałem i podłączyłem napięcie zgodnie z poniższym schematem napięcie do pinów 8 i 16 i układ sie nie grzeje.
Także diody swiecą jak kabelkiem połączyłem z ominięciem expandera więc nie ma zwarcia.
Na zdjęciach płytka z obydwu stron i sprawdziłem napięcie jest 4,95V na wszystkim trzech pinach w lewym pionie

Obrazek

Obrazek

Obrazek

a może ten expander nie jest identyczny z tym wylutowanym? (u góry oryginalny a na dole zamiennik ten, który się grzeje)

Obrazek

Awatar użytkownika
ACeK
-
-
Posty: 1522
Rejestracja: 30 mar 2003, o 19:35
Lokalizacja: Kielce

Re: PCF8574T problem

Postautor: ACeK » 29 mar 2014, o 06:22

Obrazek Jesli uklad sie nie grzeje to dobra wiadomosc :P To teraz zrob tak:
-> podlacz pod plytke zasilanie (bez wlutowanego ukladu)
-> ustaw miernik na amperomierz
-> podlacz koncowke masy amperomierza na minus zasilania na plytce
-> plus amperomierza podlacz na oporniki (od stronu ukladu) przy diodach (to jest dokladnie to samo co robiles kabelkiem)
-> sprawdz jaki plynie prad oraz czy zapala sie tylko jedna dioda
Jesli wszystko jest ok (nie ma zwarc pomiedzy scieszkami na plytce) to wlutuj uklad scalony :idea: podlacz tylko zasilanie plus i minus nic wiecej do plytki. Sprawdz czy sie grzeje. Jesli tak to wylutuj wszystkie oporniki (6 od ledow) sprawdz czy sie nie grzeje. Jesli jest zimny zacznij po kolei wlutowac oporniki i sprawdzac czy uklad sie nie grzeje. Jesli jest zimny dodaj sterowanie ukladu Obrazek

Awatar użytkownika
rafal.220
-
-
Posty: 1274
Rejestracja: 27 paź 2012, o 15:46

Re: PCF8574T problem

Postautor: rafal.220 » 29 mar 2014, o 15:29

Tam na zdjęciu na tym oryginalnym expanderze jest jakiś mostek pomiędzy nóżką 7 a 8. Sprawdź czy to jest pozostałość cyny po wlutowaniu, czy może jakiś cieniutki drucik.

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

Re: PCF8574T problem

Postautor: mariomaster » 29 mar 2014, o 19:05

Tam na zdjęciu na tym oryginalnym expanderze jest jakiś mostek pomiędzy nóżką 7 a 8. Sprawdź czy to jest pozostałość cyny po wlutowaniu, czy może jakiś cieniutki drucik.
Nie no tego oryginalnego już nie czyściłem skoro i tak spalony ale dzięki za spostrzegawczość.
A czy te expandery są identyczne bo może jest jakaś różnica między nimi chociaż te inne cyfry to pewnie jakiś numer serii itd.

Awatar użytkownika
ACeK
-
-
Posty: 1522
Rejestracja: 30 mar 2003, o 19:35
Lokalizacja: Kielce

Re: PCF8574T problem

Postautor: ACeK » 29 mar 2014, o 19:47

A czy te expandery są identyczne bo może jest jakaś różnica między nimi chociaż te inne cyfry to pewnie jakiś numer serii itd.
Obrazek Tak sa identyczne Obrazek

mariomaster
-
-
Posty: 8
Rejestracja: 16 mar 2014, o 21:39

Re: PCF8574T problem

Postautor: mariomaster » 1 maja 2014, o 19:01

Sprawa się wyjaśniła i po zakupie u innego sprzedawcy wcale się nie grzeją więc były felerne a te nowe działają bez zarzutu.

Wróć do „Elektronika - tematy dowolne”

Kto jest online

Użytkownicy przeglądający to forum: ArianeMa, Bing [Bot], Google [Bot], MaragretPi i 169 gości