Aktyw Forum

Zarejestruj się na forum.ep.com.pl i zgłoś swój akces do Aktywu Forum. Jeśli jesteś już zarejestrowany wystarczy, że się zalogujesz.

Sprawdź punkty Zarejestruj się

AT91SAM7S256 - Czym zaprogramować? Niby banalne pytanie.

_Wojciech_
-
-
Posty: 269
Rejestracja: 1 kwie 2003, o 20:32
Lokalizacja: Bielsko-Biała

AT91SAM7S256 - Czym zaprogramować? Niby banalne pytanie.

Postautor: _Wojciech_ » 31 gru 2007, o 10:44

Witam.

Niby banalny problem...
Czym zaprogramować rodzinę uC ARM SAM7 Atmela?
Kurcze nie ma schematu kabla! Ściągnąłem oprogramowanie AT91-ISP (z programatorem SAM-BA no i wszystko ładnie ale nie pisze najważniejszego - JAK PODŁĄCZYĆ PC Z uC! Mam płytę uruchomieniową ZL11ARM (KAMAMI). Można sobie do tego dokupić programator ZL14PRG ale mam dziwną obawę, że on jest raczej do ARMów LPCXXX. Bo jakoś tak jest opisany jakby był dedykowany dla tych właśnie układów.

Więc mam banalne pytania:
1. Jaki jest schemat kabla, którym mogę programować ISP uC ARM Atmela (SAM7) poprzez złącze RS w PC?
2. Jakim programem? Czy ta SAM-BA jest OK?
I jeszcze jedno: czy programator KAMAMI ZL14PRG działa z Atmelami (konkretnie z jakim programem)?

Pozdrawiam,
Wojciech

radzio
Moderator
Moderator
Posty: 967
Rejestracja: 13 maja 2003, o 10:33
Lokalizacja: Sosnowiec
Kontaktowanie:

Postautor: radzio » 31 gru 2007, o 15:27

ZL14PRG działa wyśmienicie z AT91SAM7S256 na płytce ZL11ARM. Do programowania najlepiej wykorzystać program OpenOCD.

_Wojciech_
-
-
Posty: 269
Rejestracja: 1 kwie 2003, o 20:32
Lokalizacja: Bielsko-Biała

Postautor: _Wojciech_ » 31 gru 2007, o 16:19

Wielkie dzięki za pomoc, dobrze wiedzieć, że ten programator działa z Atmelami.
Jeszcze takie pytania:
1. A da się programować ten uC poprzez łącze RS? Konkretnie na tej płycie są wyprowadzone porty COM0 i COM1. I teraz czy można poprzez któryś z nich wgrywać program kablem RS "1 do 1"? Tak jak to jest opisane w książce Lucjana Bryndzy dla LPCXXX? Jeśli tak, to czym?
2. A próbowałeś coś robić z tym programem SAM-BA Atmela?

Pozdrawiam,
Wojciech

MiW
-
-
Posty: 8
Rejestracja: 16 mar 2007, o 07:46
Lokalizacja: Kraków
Kontaktowanie:

Postautor: MiW » 26 paź 2008, o 22:24

Ja używam SAM-By :607: . Wystarczy mieć zrobiony interfejs USB (dwa tranzystory i coś tam jeszcze) i działa. Oprócz tego świadomość posiadania USB 2.0- bezcenna!
Schemat obwodów do USB i instrukcja obsługi SAMBy jest w tej instrukcji obsługi pewnego modułu uruchomieniowego pewnej firmy: http://mikrosterowniki.pl/dokumentacje/ ... _instr.pdf . Mam nadzieję, że ten link zostanie mi wybaczony.

Sławek5
-
-
Posty: 485
Rejestracja: 15 sie 2003, o 16:40
Lokalizacja: Szczecin
Kontaktowanie:

Postautor: Sławek5 » 18 lut 2009, o 06:36

Złożyłem układ w którym jest zastosowany ten uC.
Zatosowałem się zgodnie z instrukcją programowania. Zrobiłem tak:
Założyłem zworkę na pin TST, włączyłem zasilanie, odczekałem ok 10s, wyłączyłem zasilanie, zdjąłem zworkę.
Włączyłem zasilanie i podłączyłem przewód USB do komputera.
W tym miejscu powinien wykryć "AT91xxTest Board" a ja mam ciągle komunikat, że nie rozpoznano urządzenia USB.

Co ja mam zrobić, nie wiem od czego zacząć, układ sprawdziłem i jest dobrze.
Prosze o pomoc, bo nie mogę sobie poradzić.
Co jest źle?

MiW
-
-
Posty: 8
Rejestracja: 16 mar 2007, o 07:46
Lokalizacja: Kraków
Kontaktowanie:

Postautor: MiW » 18 lut 2009, o 10:42

Sterownik zainstalowałeś? :610:

Sławek5
-
-
Posty: 485
Rejestracja: 15 sie 2003, o 16:40
Lokalizacja: Szczecin
Kontaktowanie:

Postautor: Sławek5 » 18 lut 2009, o 13:11

Jakie sterowniki.
Zainstalowałem program SAM-BA ze strony Atmela i w opisie było ze po podłączeniu wykryje go jako test board.

Możesz mi cos więcej opisać?

MiW
-
-
Posty: 8
Rejestracja: 16 mar 2007, o 07:46
Lokalizacja: Kraków
Kontaktowanie:

Postautor: MiW » 18 lut 2009, o 17:36

Zakładasz zworkę TST, i podajesz wysoki stan na piny P0:P2. Włączasz zasilanie i czekasz jakieś 3 sekundy.
Wyłączasz zasilanie, zdejmujesz zworki, znowu włączasz i masz kontakt USB.
Jeżeli nie masz, to masz zły interfejs USB/kwarc/klątwę od koleżanki/inne nieuleczalne paskudztwo.

Sławek5
-
-
Posty: 485
Rejestracja: 15 sie 2003, o 16:40
Lokalizacja: Szczecin
Kontaktowanie:

Postautor: Sławek5 » 18 lut 2009, o 18:13

Nie wiem tylko jakie to paskudztwo, bo robiłem zgodnie z tym opisem i nie działa.
czy SAM-BA musi byc uruchomiona? i co ja mam z tym zrobić?

MiW
-
-
Posty: 8
Rejestracja: 16 mar 2007, o 07:46
Lokalizacja: Kraków
Kontaktowanie:

Postautor: MiW » 18 lut 2009, o 18:40

Potrzebny schemat interfejsu

Sławek5
-
-
Posty: 485
Rejestracja: 15 sie 2003, o 16:40
Lokalizacja: Szczecin
Kontaktowanie:

Postautor: Sławek5 » 18 lut 2009, o 18:52

Tylko bez T1 bo zamiast niego jest rezystor 1,5k do zasilania
Załączniki
usb.jpg
schemat
usb.jpg (12.84 KiB) Przejrzano 14693 razy

MiW
-
-
Posty: 8
Rejestracja: 16 mar 2007, o 07:46
Lokalizacja: Kraków
Kontaktowanie:

Postautor: MiW » 18 lut 2009, o 21:20

Jeżeli to ma taki schemat, to to ma działać. Po czynnościach z wprowadzaniem w stan programowania i włączeniu zasilania podłączasz wtyczkę USB i ma się wykryć nowe urządzenie USB. Jeżeli się wykryło, to układ działa.
Jeżeli nie ma sterownika, trzeba mu wynaleźć w jakimś folderze Sam-By.

adamsz
-
-
Posty: 1
Rejestracja: 20 lip 2009, o 11:12
Lokalizacja: Kalisz
Kontaktowanie:

Postautor: adamsz » 20 lip 2009, o 11:15

Witam,
a czy mógłby ktoś powiedzieć po co jest ten rezystor podciągający do PA25 i PA24? Dlaczego akurat do tych portów?

Szukałem w necie i nigdzie nie ma po co. Znalazłem też schematy, gdzie w ogóle nie ma tych rezystorów.

Z góry dzięki za pomoc.

Wróć do „ARM (STM32, NXP, Stellaris i inne)”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 2 gości