Aktyw Forum

Zarejestruj się na forum.ep.com.pl i zgłoś swój akces do Aktywu Forum. Jeśli jesteś już zarejestrowany wystarczy, że się zalogujesz.

Sprawdź punkty Zarejestruj się

Problem z mostkiem H

lipczyk
-
-
Posty: 41
Rejestracja: 24 lut 2012, o 19:44

Problem z mostkiem H

Postautor: lipczyk » 19 maja 2012, o 23:37

Zbudowałem sobie regulator do silników bazując na artykule http://ep.com.pl/files/2493.pdf.
Ze względu na duże prądy tranzystory T1-T4 umieściłem na oddzielnej płytce. Pierwsze próby się udały. Musiałem jednak nieco zmodyfikować płytkę ze wspomnianymi tranzystorami i podczas montażu niechcący zwarłem masę baterii i mostka (sam sterownik był odłączony) i silnik ruszył. Jednak wystarczyło podłączyć sterownik (procek nie był zasilany) i wszystko było OK. Kolejnej próby z włączonym zasilaniem jeszcze nie robiłem. Mostek sprawdzałem i nic nie znalazłem.
Czy tranzystor unipolarny j.w. może dostać jakiś "zbłąkany potencjał" i się otworzyć?
Czy mogę sprawdzić, czy tranzystory nie są uszkodzone (możliwe bo sterownik na koniec trochę szalał, ale dymu nie było) bez odlutowywania ich?
Może jakieś inne sugestie co jest nie tak?
Z góry dziękuję za pomoc.

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Problem z mostkiem H

Postautor: Tomasz Gumny » 20 maja 2012, o 01:44

Podłączanie zasilania do mostka H z odłączonym lub niezasilanym sterowaniem to bardzo kiepski pomysł. Podobnie zresztą jak pozostawianie przez autora bramek i baz bez jakiegokolwiek podwieszenia na czas zerowania procesora.
Może jakieś inne sugestie co jest nie tak?
A jakie są objawy?

lipczyk
-
-
Posty: 41
Rejestracja: 24 lut 2012, o 19:44

Re: Problem z mostkiem H

Postautor: lipczyk » 20 maja 2012, o 09:03

Innych objawów niema. Dodam, że bliźniaczy mostek się nie załącza w sytuacji j.w.
Zmontuję go w całość i zobaczę, czy w ogóle działa.
Do programowania procesora odpinam sterownik, a zasilanie włączyło mi się niechcący.
Rozumiem, że taki mostek bez sterownika może być nieprzewidywalny.

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Problem z mostkiem H

Postautor: Tomasz Gumny » 20 maja 2012, o 10:16

Innych objawów niema.
A jakie były te pierwsze, bo to, że:
zwarłem masę baterii i mostka (sam sterownik był odłączony) i silnik ruszył
można różnie rozumieć.
Rozumiem, że taki mostek bez sterownika może być nieprzewidywalny.
Ze zwarciem źródła zasilania włącznie..

lipczyk
-
-
Posty: 41
Rejestracja: 24 lut 2012, o 19:44

Re: Problem z mostkiem H

Postautor: lipczyk » 22 maja 2012, o 12:19

Jednak tranzystor się spalił. Ponieważ był przykręcony do 3kg aluminium, nie było to efektowne.

rotab
-
-
Posty: 6
Rejestracja: 5 lip 2012, o 13:35

Re: Problem z mostkiem H

Postautor: rotab » 9 lip 2012, o 08:09

Witaj
Późno, ale lepiej niż nigdy. Metoda dla twojego działania jest prosta - pomiędzy końcówki rezystorów R11, R12,R13,R14 o piny uC dodaj rezystory coś pomiędzy 10k a 47 k podłączone do masy. Zarówno MOSFET P jak i N będą w stanie odcięcia bez podłączenia do sterowania od czegokolwiek prąd przez silnik powinien być praktycznie 0 (zero). Rozumiem, że zasilanie około 15V w fazie prób jest z zasilacza z ograniczeniem prądu. Zamiast silnika włącz żarówkę na tak około 24V - jak zaświeci to papa (ale nic gorszego nie powinno się stać), jak nie zaświeci to jeszcze nie czas na radość - weź miernik prądu, w szereg z żarówką i pomiar. Jak prąd (kilkadziesiąt mA płynie to źle, jak nie to...? ). I to by było na tyle wg. prof. mniemanologi stosowanej.

Wróć do „Elektronika - tematy dowolne”

Kto jest online

Użytkownicy przeglądający to forum: eftretrdf i 24 gości