Aktyw Forum

Zarejestruj się na forum.ep.com.pl i zgłoś swój akces do Aktywu Forum. Jeśli jesteś już zarejestrowany wystarczy, że się zalogujesz.

Sprawdź punkty Zarejestruj się

Wzmocnienie sygnały z czujnika indukcyjnego

Moderatorzy: Jacek Bogusz, Moderatorzy

Marek.S
-
-
Posty: 8
Rejestracja: 28 paź 2011, o 09:57

Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Marek.S » 28 paź 2011, o 10:29

Witam
Mam pewien problem, a mianowicie zrobiłem układ zapłonowy CDI, moduł, cewkę WN, impulsator oraz odpowiednio wszystko zgrałem z kołem zamachowym. Wszystko ładnie pięknie motorower pali, jeździ lecz problem pojawia się przy niskiej prędkości obrotowej oraz podczas odpalania. Dokładniej to impulsator (cewka z przekaźnika 12V na ferromagnetycznym rdzeniu) daje za niskie napięcie przy niskich obrotach by wysterować tyrystor. Stąd też mój krok poszedł w stronę wzmocnienia tegoż sygnału (sinus 100-1200mV 8-200Hz) wybór padł na opamp'a. Teraz miałbym prośbę do bardziej obeznanych w temacie o weryfikację czy schemat który skleiłem (głównie z noty katalogowej) ma rację bytu ?

Przyznam się bez bicia że na WO (jeszcze zbytnio) się nie znam stąd też dla kogoś mogą tam być totalne babulki.

Jak widać układ odwracający (niestety nie potrafię go przerobić na nieodwracający) stąd też na wyjściu tranzystor który znów przesuwa fazę oraz stabilizator na Zenerce by nie uszkodzić tyrystora nadmiernym napięciem na bramkę (max 1.5V wg datasheeta) .

Obrazek

Żeby nie było nieporozumień układ nie zlicza napięcia względem prędkości obrotowej tylko potrzebuje impuls do wyzwolenia.

Awatar użytkownika
Medicus
-
-
Posty: 316
Rejestracja: 9 paź 2007, o 22:31
Lokalizacja: Londyn

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Medicus » 29 paź 2011, o 20:38

Zmień opampa bo ten co dałeś wymaga symetrycznego zasilania.

Xweldog
-
-
Posty: 231
Rejestracja: 16 sty 2009, o 16:40
Lokalizacja: Wrocław

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Xweldog » 29 paź 2011, o 21:24

Akurat tu nie, jest "podzielone" na dwie połowy na 2x200kΩ.

Awatar użytkownika
Medicus
-
-
Posty: 316
Rejestracja: 9 paź 2007, o 22:31
Lokalizacja: Londyn

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Medicus » 29 paź 2011, o 22:39

Akurat tu nie, jest "podzielone" na dwie połowy na 2x200kΩ.
Dobrze, ale można jeszcze lepiej, na połowie zwykłego LM358 zrobić wszystko i nie trzeba nic kombinować z symetrią, a jeszcze lepiej to użyć LM311 on doskonale chodzi na asymetrycznym zasilaniu i tutaj byłby w sam raz.

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Tomasz Gumny » 29 paź 2011, o 23:21

Układ może i jest poprawny elektrycznie, ale nie koncepcyjnie:
:arrow: przy niepracującym silniku będą wzmacniane wszelkie śmieci z przewodów i impulsatora - koniecznie trzeba tu zrobić histerezę;
:arrow: układ inwertera na tranzystorze jest niepoprawny - baza wisi w powietrzu, dioda Zenera działa tylko w kierunku przewodzenia, itp.
Do wzmocnienia impulsu z cewki wystarczyłby jeden stopień na tranzystorze...

Marek.S
-
-
Posty: 8
Rejestracja: 28 paź 2011, o 09:57

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Marek.S » 30 paź 2011, o 01:40

Witam

Jak pisałem jestem ciemno zielony* jeśli chodzi o WO, stąd prośba o modyfikację schematu.

Jeśli jeszcze jakieś dane są potrzebne to podam.


*Staram się to pojąć choć bez osoby która wytłumaczy trochę ciężko...

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Tomasz Gumny » 30 paź 2011, o 01:50

Jeśli jeszcze jakieś dane są potrzebne to podam.
Jak to było podłączone dotychczas?
W którym momencie ma być zapalany tyrystor - przy przejściu przez zero czy w minimum lub maksimum napięcia na cewce impulsatora?
Czy nie jest potrzebne jakieś wyprzedzenie zapłonu zależne od obrotów?

Marek.S
-
-
Posty: 8
Rejestracja: 28 paź 2011, o 09:57

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Marek.S » 30 paź 2011, o 11:49

Schemat samego modułu CDI którym proszę się sugerować:

Obrazek

Wyzwalany dodatnim szczytem sinusa. Impulsator jeden koniec do masy, drugi do wejścia "TIMING PULSE IN" fazę mogę przesunąć o 180° zmieniając podpięcie kabli.

Wyprzedzenie teoretycznie jest sprawą pomijalną bo to silnik 2T w którym na seryjnych platynkach wyprzedzenie było na "sztywno".


Edit://


Znalazłem jeszcze opracowanie nt CDI w samochodach i zaciekawiła mnie jedna przystawka sądzę że jest to właśnie "wzmacniacz wyzwalacza" :

http://www.molla.org/DIY-CDI/SC-DIY-CDI ... -hires.pdf

str.8 Reluctor Trigger

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Tomasz Gumny » 30 paź 2011, o 12:47

str.8 Reluctor Trigger
Ten układ powinien wystarczyć. Trochę tam jest pokręcona polaryzacja bazy, ale powinno działać z cewką dającą przynajmniej kilka wolt.
W sumie dlaczego nie "przełącznik" halotronowy, np. TLE4945 albo coś wyszarpniętego ze starego wentylatorka DC.

Marek.S
-
-
Posty: 8
Rejestracja: 28 paź 2011, o 09:57

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Marek.S » 30 paź 2011, o 13:23

dającą przynajmniej kilka wolt
Właśnie :/ a u mnie jak wczoraj odpaliłem na "farta" (cewka świetlna 12V zamiast impulsatora) to napięcie na gołym (bez obciążenia, ani modułu) wyjściu z impulsatora wyniosło 1.2V gdzieś przy 2k RPM (mierzone starym ruskim analogowym miernikiem) podczas rozruchu ten sam impulsator daje max 0.5-0.6V lecz to i tak trzeba pomachać starterem kilka razy (raz za razem)

Czemu nie hall ? Bo myślę że może być zbyt czuły, nabijać sobie "urojone' sygnały w związku z bliską obecnością magneta, a poza tym nie chciałbym już dziergać w deklu i karterach w celu montażu.

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Tomasz Gumny » 30 paź 2011, o 14:25

Z budowy modułu CDI wynika, że C2 (oznaczenia z wcześniejszego schematu) jest ładowany z magneto w obwodzie D2, C2, COIL do dość wysokiego napięcia a następnie tyrystor go rozładowuje w obwodzie COIL, C2, Q1 albo D1 i D2. Zatem tyrystor musi być normalnie wyłączony a sygnał z przerywacza go zapala przez podanie +12V. Jeśli tak, to proponuję przetestować taki układ:
cdi1.gif
cdi1.gif (2.78 KiB) Przejrzano 8487 razy
R1=10kΩ, R2=1kΩ (może być konieczne zmniejszenie do kilkuset Ω), D1=1N4148, C1=kilkadziesiąt nF, Q2=BC547. Jeśli na 12V mogą się pojawiać szpilki wysokiego napięcia, to cały układ najlepiej zasilać przez kilkudziesiecioomowy rezystor a zasilanie zabezpieczyć transilem ostatecznie większą diodą Zenera. Równolegle do cewki (czujnika) daj rezystor 1..10kΩ.

Marek.S
-
-
Posty: 8
Rejestracja: 28 paź 2011, o 09:57

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Marek.S » 30 paź 2011, o 21:58

sygnał z przerywacza go zapala przez podanie +12V
Sygnał z impulsatora go zapala poprzez podanie ??V lecz wątpię że 12V, reszta się zgadza.

Układ skleciłem w szufladowego pająka. R2=P1=1k D1=RGP10G Q2=BC184 C1 testowałem 22n, 47n 68n, 100n. Na 100n uzyskałem stabilną iskrę bez zbędnego machania starterem. Jedyne czego nie podpiąłem to rezystora równolegle do "czujki". Jedno co mnie martwi to że tranzystor się bardzo grzeje (możliwe że to wina tego że dałem inny)

Jutro skoczę do sklepu po nowe pewne elementy na cały moduł i zalutuje na PCB bo teraz to też jeden wielki po izolowany pająk wciśnięty do pudełka po dużych tiktakach.

Tak więc jutro zdam relację jak odpalę silnik i pomęczę po drogach (lub też i nie).

Na razie dziękuję za pomoc.

PS: Zrobiłem (tak dla ciekawości) też ten wyzwalacz na Halla (wymontowałem z starego FDD) z w/w PDF'a lecz działa mi to na opak w polu magn. napięcie na wyjściu zanika, a chyba powinno być na opak. Nie testowałem go przy silniku.

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Tomasz Gumny » 30 paź 2011, o 22:33

[...] wątpię że 12V
Nie wiem jakie napięcie jest w instalcji skutera... 6V? Grzanie tranzystora jest dość niepokojące, bo nie bardzo widzę skąd miałaby się tam wydzielać jakaś większa moc. Uce jest ograniczone przez Ug tyrystora, prąd kolektora też nie może być większy niż kilka mA.
Chyba, że prąd bazy jest znaczny, ale pisałeś, że w cewce indukują się pojedyncze wolty a cewka od przekaźnika na 12V powinna mieć dobrych kilkaset om.
PS: Zrobiłem (tak dla ciekawości) też ten wyzwalacz na Halla (wymontowałem z starego FDD) z w/w PDF'a lecz działa mi to na opak w polu magn. napięcie na wyjściu zanika, a chyba powinno być na opak.
Są różne wersje czujników. Ten, o którym wspomniałem zmienia stan na wyjściu przy zmianie kierunku sił pola (z pewną histerezą). Czasem konieczne jest zanegowanie wyjścia a może w pewnych wypadkach wystarczyłoby odwrócenie czujnika?

Marek.S
-
-
Posty: 8
Rejestracja: 28 paź 2011, o 09:57

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Marek.S » 30 paź 2011, o 23:47

Napięcie instalacji jak najbardziej jest 12V lecz seryjnie układ zapłonowy i reszta instalacji to "odseparowane" od siebie układy. Do zapłony wchodzi tylko impulsator, moduł, cewka ładująca WN, cewka (a właściwie transformator) WN i świeca. Światła, ładowanie i inne bibeloty posiadają swój własny zestaw cewek zasilających (12V). Wspólne w obu to jedynie masa. I właśnie seryjnie tyrystor odpala napięciem tylko i wyłącznie wyindukowanym w czujniku lecz jakie wytwarza fabryczny impulsator to to nie wiem :/
Trochę to takie chodzenie ślepca po oznaczonym polu minowym...

Cewka z przekaźnika jaką mam ma jak dobrze pamiętam coś koło 200-300Ω.
Ale nic jutro kupie części i będę działał, oraz dam znać co i jak.

Marek.S
-
-
Posty: 8
Rejestracja: 28 paź 2011, o 09:57

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Marek.S » 1 lis 2011, o 00:48

Witam

W sklepie nie byłem bo przenieśli się kolejne 20km dalej (na rowerek i moją kondycje trochę za dużo) :/ , ale rozlutowałem stary odtwarzacz CD. Podmieniłem tranzystor na BC547 no i niestety kiszka :( Iskra jest a silnik nie odpali bo go zalewa (za późny zapłon) nawet zmiana kabli z impulsatora nie pomaga. Rano pokombinuje i dodam kolejny "człon" wzmacniacza by znów przesunąć się w fazie o kolejne 180° i tym samym wrócić do pierwotnego sygnału (przynajmniej tak mi się wydaje na mój chłopski rozum).

Awatar użytkownika
Tomasz Gumny
-
-
Posty: 685
Rejestracja: 4 lut 2004, o 23:31
Lokalizacja: Trzcianka/Poznań

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: Tomasz Gumny » 1 lis 2011, o 01:32

[...]dodam kolejny "człon" wzmacniacza by znów przesunąć się w fazie o kolejne 180°
Ten sam efekt da zamiana przewodów z impulsatora.
Daj równolegle do cewki impulsatora rezystor 1kΩ, zwiększ R1 do 10kΩ i C1 do 1µF.
Z białego LED-a można zrobić całkiem skuteczny stroboskop - może warto sprawdzać w ten sposób moment zapłonu?

kamilkat
-
-
Posty: 5
Rejestracja: 4 sie 2011, o 09:02
Lokalizacja: Zgierz

Re: Wzmocnienie sygnały z czujnika indukcyjnego

Postautor: kamilkat » 9 lip 2014, o 08:45

Nie mam zdania.

Wróć do „Elektronika - tematy dowolne”

Kto jest online

Użytkownicy przeglądający to forum: Google [Bot] i 90 gości