Aktyw Forum

Zarejestruj się na forum.ep.com.pl i zgłoś swój akces do Aktywu Forum. Jeśli jesteś już zarejestrowany wystarczy, że się zalogujesz.

Sprawdź punkty Zarejestruj się

Migająca dioda nie działa poprawnie...

Moderatorzy: Jacek Bogusz, Moderatorzy

Awatar użytkownika
Darlington
-
-
Posty: 574
Rejestracja: 12 lis 2007, o 18:18
Lokalizacja: stąd!

Migająca dioda nie działa poprawnie...

Postautor: Darlington » 20 sie 2009, o 22:44

Witam, zbudowałem układ na pająku "migająca dioda"
Obrazek
Ze strony http://www.eres.alpha.pl/elektronika/ar ... cle_id=188

Zastosowałem rezystor 1,91kΩ i diodę niebieską.
Układ nie działa poprawnie, dioda zamiast migać, świeci światłem ciągłym.
Co może być źle?

Dodano po namyśle:

Zmierzyłem trochę i:
- na diodzie 3V
- na kondensatorze 11,05V
- Uce=8,08V
- Ube=7,3V

Ponadto zauważyłem, że dioda zaczyna migać, jak dotknę końcówkami pomiarowymi bazy i emitera... czyli chyba coś z tranzystorem jak myślicie?
Czy zły kolor diody i dlatego?

Edit: Scalenie... po takim stażu, mógłbyś się nauczyć nie pisania postów jeden pod drugim (bez naprawdę wyraźnej potrzeby - np. odświeżenie po dłuugim czasie).
Pajączek.
Ostatnio zmieniony 21 sie 2009, o 11:26 przez Darlington, łącznie zmieniany 2 razy.

Marian B
-
-
Posty: 189
Rejestracja: 27 sty 2008, o 16:37
Lokalizacja: Szczecinek

Postautor: Marian B » 21 sie 2009, o 08:47

Moim zdaniem, tego typu układziki są bez sensu, gdyż wykorzystane są tu zjawiska fizyczne nie stabilne z natury. Wszystko zależy od rodzaju tranzystora, a nawet konkretnego egzemplarza, od temperatury zewnętrznej, doboru elementów. Taki układ dobry jest jedynie jako poglądowa ilustracja pewnych zjawisk mogących zachodzić w tym układzie.
Migającą diodę można bez problemu nabyć "gotową", nie różni się wyglądem od zwykłej, cena jest "taka sama", i potrzebny jest tylko rezystor ograniczający, taki jak do każdej diody.

Awatar użytkownika
almatea
-
-
Posty: 240
Rejestracja: 12 gru 2003, o 17:02
Lokalizacja: Brzeszcze
Kontaktowanie:

Postautor: almatea » 21 sie 2009, o 10:55

Jeśli mogę, to do tego celu polecę Ci specjalizowany układ LM3909, posiadający 8 pinów.
Do poprawnej pracy wymaga jedynie diody oraz kondensatora.
W jednej z początkowych EdW, można było znaleźć układzik "Intrygująca mrygałka", zbudowany właśnie z wykorzystaniem tegoż scalaczka.
Ściągnąłem aplikację LM3909 i wychodzi na to, że to "bardzo poważny" układ, wykorzystywany między innymi do budowy sygnalizatorów w ratownictwie, gdzie wymagany jest jak najmniejszy pobór prądu a przez to wpływający na długość pracy.
Gotowy układ z zastosowaną diodą ultra jasną 1000 mcd razem pobiera prąd rzędu uA przy zasilaniu z ogniwa 1,5V!!!
Na baterii R20 porządnej firmy działał u mnie prawie dwa lata!!!!

Polecam

Awatar użytkownika
pajaczek
Moderator
Moderator
Posty: 2653
Rejestracja: 24 sty 2005, o 00:39
Lokalizacja: Winny gród

Postautor: pajaczek » 21 sie 2009, o 11:40

Marian B, Sądzę, że Darlingtonowi bardziej chodziło o nauczenie się czegoś, niż samo miganie ;)

almatea, Patrząc na cenę... to ja podziękuję. Zaproponuję do tego celu 555 (o którym ostatnio sporo w EP), i kosztuje grosze.
Gotowy układ z zastosowaną diodą ultra jasną 1000 mcd razem pobiera prąd rzędu uA przy zasilaniu z ogniwa 1,5V!!!
Co prawda wszystko jest względne, ale albo te błyski były baardzo rzadkie, a Ty podajesz oczywiście średni prąd. Albo jednak podajesz bez poboru diody. Te 1000mcd jakie podaje producent diody to przy 20mA (zapewne), załóżmy sterowanie PWM z wypełnieniem 1/10, pozostawienie prądu katalogowego, i 1 sek błysk 1 sek przerwy, co już daje nam pobór ... ?? I to dla samej diody (pamiętając, że jasność "błysku" będzie niższa niż 1000mcd). Oczywiście dla błysków krótszych i rzadszych będzie to optymistyczniejsze.

Awatar użytkownika
Darlington
-
-
Posty: 574
Rejestracja: 12 lis 2007, o 18:18
Lokalizacja: stąd!

Postautor: Darlington » 21 sie 2009, o 17:39

Panowie wiem, że to można zrobić na scalakach i z gotowa migającą diodą (a da się tam regulować częstość błyśnięć?), ale ja chcę zrobić na tym układzie, bo jest prosty a to mój pierwszy układ. Te co podaliście, byłyby dla mnie za trudne.
Dzisiaj kupiłem BC107 później sprawdzę, czy na nim będzie działać prawidłowo.

Edit:
To na 100% nie wina zasilania, bo dałem równolegle z tamtym rezystorem taki sam rezystor i tylko dioda mocniej zaświeciła, ale migania brak, dałem szeregowo z zasilaczem też baterię "paluszka" 1,5V i to samo, dwa paluszki dające w sumie 3,1V i to samo...

Więc podniesienie napięcia zasilającego układ o 3,1V dało tylko mocniejsze świecenie diody ale brak migania...

edit2:
Wlutowałem BC107C w miejsce tamtego i to samo...
Wyprowadzeń nie pomyliłem, sprawdziłem w datasheet'cie http://cdil.com/datasheets/bc107_8_9_a_b_c.pdf
Nie miga...

Pomiary:
Uce=9,24V
LED 2,69V
Kond. 11,93V
Rezystor 0,68V
Ubc=0,53V

Jak zewrę bazę i emiter, to dioda świeci dużo jaśniej.

To może pokaże zdjęcie zobaczcie czy są jakieś błędy montażowe bo ja nie widzę błędów
Obrazek

Ja już nie wiem co jest z tym układem. Pomocy.

wojtek19
-
-
Posty: 75
Rejestracja: 14 cze 2007, o 06:54
Lokalizacja: śląsk

Postautor: wojtek19 » 22 wrz 2009, o 07:17

witaj
układzik pracuje jesli zastosujesz sprawne elementy.
Ja go zmontowałem z dostępnych mi elementów na tzw "pająka" i fajnie mryga.
Zastosowałem dowolny tranzystor BC107, rezystor 10k, kondensator 220uF i diodę czerwoną bo taką miałem.

Wróć do „Elektronika - tematy dowolne”

Kto jest online

Użytkownicy przeglądający to forum: Google [Bot] i 71 gości